hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3041) Within a task, the value ofJobConf.getOutputPath() method is modified
Date Mon, 24 Mar 2008 15:41:24 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3041?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12581570#action_12581570
] 

Owen O'Malley commented on HADOOP-3041:
---------------------------------------

I think we need to revert this in 16.2. Breaking compatibility from 0.16.1 is worse that living
with a recognized change from 0.16.0. Changing from getOutputPath makes the API inconsistent
with setOutputPath, so for 0.17, I propose:

 * moving getOutputPath to be the final one
 * rename getCurrentOutputPath to getWorkOutputDirectory

> Within a task, the value ofJobConf.getOutputPath() method is modified
> ---------------------------------------------------------------------
>
>                 Key: HADOOP-3041
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3041
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: mapred
>    Affects Versions: 0.16.1
>         Environment: all
>            Reporter: Alejandro Abdelnur
>            Assignee: Amareshwari Sriramadasu
>            Priority: Blocker
>             Fix For: 0.16.2
>
>         Attachments: patch-3041-0.16.2.txt, patch-3041.txt
>
>
> Until 0.16.0 the value of the getOutputPath() method, if queried within a task, pointed
to the part file assigned to the task. 
> For example: /user/foo/myoutput/part_00000
> In 0.16.1, now it returns an internal hadoop for the task output temporary location.
> For the above example: /user/foo/myoutput/_temporary/part_00000
> This change breaks applications that use the getOutputPath() to compute other directories.
> IMO, this has always being broken, Hadoop should not change the values of properties
injected by the client, instead it should use private properties or internal helper methods.


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message