hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sanjay Radia (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-2916) Refactor src structure, but leave package structure along
Date Tue, 04 Mar 2008 00:18:51 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-2916?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12574798#action_12574798

Sanjay Radia commented on HADOOP-2916:

>> src/core/org.apache.hadoop.dfs

>Do you really mean to use directories with dots in their names, or do you mean slashes?
That's an unusual naming convention for java source... >What would the full path of an
HDFS source file be?

No it would be slashes  - the standard convention - I was trying to clarify where the package
structure starts.
Sorry for the confusion.

>Also, we should stop using the term 'dfs' and consistently use 'hdfs' instead.  .....
The package will be renamed to hdfs as I noted in the description.

The purpose of this Jira is to break down the hdfs package restructuring (HADOOP 2885) so
that part of the work can be done separately.

The first phase - (this JIRA) would have NO package renames, only src tree changes.
The second phase (Jira HADOOP-2885) will do package renames  -ie hadoop.dfs will be renamed
to hadoop.fs.hdfs in this 2nd phase.

SO at the end of phased 2 (HADOOP-2885), the structure will look as you have proposed.

> Refactor src structure, but leave package structure along
> ---------------------------------------------------------
>                 Key: HADOOP-2916
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2916
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: dfs
>            Reporter: Sanjay Radia
>             Fix For: 0.17.0
> This Jira proposes that the src structure be split  as below.
>  The package structure remains the same for this Jira. (Package renaming is part of other
JIras  such as HADOOP-2885).
> The idea is that the src will be split   BEFORE the package restructuring
> The new proposed src structure is
> src/test - unchanged
> src/java - will no longer exit , its content will be move to one of core, hdfs, or mapred
> src/core - this will contain the core classes that hadoop applications need to link against.
>   It will contain client side libraries of  all fs file systems:  local, hdfs, kfs, etc
>   jar name hadoop_core.jar
>    src/core/org.apache.hadoop.{conf, fs, filechache, io, ipc, log, metrics, net, record,
security, tools, util)
>    src/core/org.apache.hadoop.dfs - this will contain only the client side parts of dfs.
>                    HADOOP-2885 will rename package dfs  to package  fs.hdfs 
> src/hdfs/org.apache.hadoop.dfs - this will contain only the server side of hdfs. 
>       HADOOP-2885 will rename package dfs  to package  fs.hdfs later; a compatible dfs.DistributedFileSystem
will be left for compatibility/
>    jar name hadoop_hdfs.jar - this jar can be used to launce NNs and DNs etc.
> src/mapred/org.apache.hadoop.mapred.*
>    Initially one jar:  hadoop_mapred.jar
>    Later this may be split into client-side and server-side jars.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message