hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From caoyuzhong <caoyuzh...@hotmail.com>
Subject errors when running the wordcount example in eclipse environment
Date Fri, 29 Feb 2008 05:32:42 GMT

Hi All,

I've set up the eclipse environment and built all of hadoop in it successfuly.
Then I tried to run the wordcount example in Eclipse but got the following error messages:
---------------
Exception in thread "main" java.lang.RuntimeException: java.io.IOException: No FileSystem
for scheme: file
    at org.apache.hadoop.mapred.JobConf.getWorkingDirectory(JobConf.java:350)
    at org.apache.hadoop.mapred.JobConf.setInputPath(JobConf.java:231)
    at org.apache.hadoop.examples.WordCount.run(WordCount.java:145)
    at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65)
    at org.apache.hadoop.examples.WordCount.main(WordCount.java:154)
Caused by: java.io.IOException: No FileSystem for scheme: file
    at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:163)
    at org.apache.hadoop.fs.FileSystem.getNamed(FileSystem.java:122)
    at org.apache.hadoop.fs.FileSystem.get(FileSystem.java:94)
    at org.apache.hadoop.mapred.JobConf.getWorkingDirectory(JobConf.java:346)
    ... 4 more
--------------

BTW, I can successfully run the wordcount example in my cgywin environment by issuing below
command:
bin/hadoop jar build/hadoop-0.16.0-examples.jar wordcount test-in test-out

How can I run it in Eclipse? Could you please help me. Thanks!

Yuzhong
2008/02/29








_________________________________________________________________
天凉了,添衣了,心动了,“七件”了 
http://get.live.cn
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message