hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hemanth Yamijala (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-2861) [HOD] Improve the user interface for the HOD commands
Date Fri, 22 Feb 2008 16:25:19 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-2861?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12571454#action_12571454
] 

Hemanth Yamijala commented on HADOOP-2861:
------------------------------------------

There are 2 models listed above:

Allen and Lohit's model of: hod <sub-command> [options]

and

Arkady's model of: hod [-a | -d | -l | -i ] [options]

I like Allen's and Lohit's suggestion better. It seems a clearer model to treat the CLI as:
command sub-command <options> model. It also has the nice side-effect of being similar
to Hadoop commands. So, we will have:

hod allocate -n num-of-nodes -D cluster-dir [other options] 
hod deallocate -D cluster-dir [other options]
hod list [other options]
hod info -D cluster-dir [other options]

If we want to type less, we could also have

hod allocate num-of-nodes cluster-dir [other options] #reads like allocate 5 nodes and put
info in cluster-dir

but that kind of brings positional arguments. So that may not be that preferable.

These form the core interface of HOD. 4 simple operations which can be combined to do other
things.

In that spirit (and related to another issue that Arkady had raised), I am thinking we should
do away with the script option. It is essentially a wrapper - that's all. Now, to help users,
we can have a wrapper script that is part of HOD. Something like:

hod-script -n num-of-nodes -D cluster-dir -s script-file [-z] [other options] # -z means don't
deallocate.

But this would a simple shell script that translates to something like:

hod allocate -n num-of-nodes -D cluster-dir
export HADOOP_CONF_DIR=cluster-dir
/bin/sh -c script-file
# if -z is specified
hod deallocate -D cluster-dir

The script option would not be a part of the core HOD interface. We thus can keep the HOD
interface simple, and doing one thing well.

We are trying to address this issue ASAP. Please do comment with what model you prefer.



> [HOD] Improve the user interface for the HOD commands
> -----------------------------------------------------
>
>                 Key: HADOOP-2861
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2861
>             Project: Hadoop Core
>          Issue Type: Improvement
>          Components: contrib/hod
>    Affects Versions: 0.16.0
>            Reporter: Hemanth Yamijala
>             Fix For: 0.16.1
>
>
> The current command line for HOD is not user-friendly or conventional. Following improvements
are required:
> - We shouldn't require the quotes around the operation.
> - Can we define a HOD_CLUSTER_DIR environment variable which would be used by default
?
> With these two, one can imagine a very simple command line for HOD. Something like:
> hod-allocate 3
> hod-deallocate
> hod-allocate 3 ~/hod-clusters/test
> hod-deallocate ~/hod-clusters/test
> This would also be backward compatible for people who're used to the current model.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message