hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-2547) remove use of 'magic number' in build.xml
Date Tue, 08 Jan 2008 20:11:34 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-2547?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12557015#action_12557015
] 

Hadoop QA commented on HADOOP-2547:
-----------------------------------

-1 overall.  Here are the results of testing the latest attachment 
http://issues.apache.org/jira/secure/attachment/12372704/2547.patch
against trunk revision .

    @author +1.  The patch does not contain any @author tags.

    javadoc +1.  The javadoc tool did not generate any warning messages.

    javac +1.  The applied patch does not generate any new compiler warnings.

    findbugs +1.  The patch does not introduce any new Findbugs warnings.

    core tests +1.  The patch passed core unit tests.

    contrib tests -1.  The patch failed contrib unit tests.

Test results: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1516/testReport/
Findbugs warnings: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1516/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Checkstyle results: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1516/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1516/console

This message is automatically generated.

> remove use of 'magic number' in build.xml
> -----------------------------------------
>
>                 Key: HADOOP-2547
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2547
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: build
>            Reporter: Hrishikesh
>            Priority: Trivial
>         Attachments: 2547.patch
>
>
> build.xml has a call to touch task as 
>  <touch datetime="01/25/1971 2:00 pm">
> it should be changed to
>  <touch millis="0"> 
> It will avoid using magic values like "01/25/1971 2:00 pm" and make the script easier
to understand

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message