hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bryan Duxbury (JIRA)" <j...@apache.org>
Subject [jira] Created: (HADOOP-2518) [hbase] Refactor HStore and internal (and related) classes into hbase.store subpackage
Date Thu, 03 Jan 2008 19:22:34 GMT
[hbase] Refactor HStore and internal (and related) classes into hbase.store subpackage
--------------------------------------------------------------------------------------

                 Key: HADOOP-2518
                 URL: https://issues.apache.org/jira/browse/HADOOP-2518
             Project: Hadoop
          Issue Type: Improvement
          Components: contrib/hbase
            Reporter: Bryan Duxbury
            Assignee: Bryan Duxbury
            Priority: Minor


HStore, the class responsible for managing data storage for column families within a region,
is a very large class with more than a few internal classes. I propose moving HStore and HStoreFile
into the hbase.store subpackage, and then moving internal classes out of HStore and into their
own package-internal classes within the subpackage. This will make the code much more readable
and manageable. In addition, it will help to logically delineate which classes are involved
in managing a store.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message