hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bryan Duxbury (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-2599) [hbase] Some minor improvements to changes in HADOOP-2443
Date Mon, 14 Jan 2008 18:10:34 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-2599?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bryan Duxbury updated HADOOP-2599:
----------------------------------

    Component/s: contrib/hbase
       Assignee: Bryan Duxbury
    Description: 
Stack made a number of suggestions for improvements in the code changes from HADOOP-2443:

Here in HConnectionManager:

+          scannerId = server.openScanner(
+            metaLocation.getRegionInfo().getRegionName(),
+            COLUMN_FAMILY_ARRAY, EMPTY_START_ROW, LATEST_TIMESTAMP,
+            null);

... EMPTY_START_ROW will work but 'startRow' would be easier to read (It'd work too - right?).

Here:

+      } while (startRow.compareTo(EMPTY_START_ROW) != 0);

.. EMPTY_ROW or a new define, LAST_ROW, would have been more readable, don't you think?

This 999... 'trick' should be done as a method - in HTableInfo? - since you do it twice:

+    Text tableKey = new Text(tableName.toString() + ",,99999999999999");

  was:
Stack made a number of suggestions for improvements in the code changes from HADOOP-2443:

Here in HConnectionManager:

+          scannerId = server.openScanner(
+            metaLocation.getRegionInfo().getRegionName(),
+            COLUMN_FAMILY_ARRAY, EMPTY_START_ROW, LATEST_TIMESTAMP,
+            null);

... EMPTY_START_ROW will work but 'startRow' would be easier to read (It'd work too - right?).

Here:

+      } while (startRow.compareTo(EMPTY_START_ROW) != 0);

.. EMPTY_ROW or a new define, LAST_ROW, would have been more readable, don't you think?

This 999... 'trick' should be done as a method - in HTableInfo? - since you do it twice:

+    Text tableKey = new Text(tableName.toString() + ",,99999999999999");

[ Show ยป ]
stack - 13/Jan/08 10:54 PM Committed. Had some minor questions - see below - but it ain't
enough to hold up patch and I'm afraid patch would rot if left hang (It touches lots of classes).
Resolving. Thanks for the patch Bryan. Here's the couple of items: Here in HConnectionManager:

+          scannerId = server.openScanner(
+            metaLocation.getRegionInfo().getRegionName(),
+            COLUMN_FAMILY_ARRAY, EMPTY_START_ROW, LATEST_TIMESTAMP,
+            null);

... EMPTY_START_ROW will work but 'startRow' would be easier to read (It'd work too - right?).
Here:

+      } while (startRow.compareTo(EMPTY_START_ROW) != 0);

.. EMPTY_ROW or a new define, LAST_ROW, would have been more readable, don't you think? This
999... 'trick' should be done as a method - in HTableInfo? - since you do it twice:

+    Text tableKey = new Text(tableName.toString() + ",,99999999999999");




> [hbase] Some minor improvements to changes in HADOOP-2443
> ---------------------------------------------------------
>
>                 Key: HADOOP-2599
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2599
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: contrib/hbase
>            Reporter: Bryan Duxbury
>            Assignee: Bryan Duxbury
>            Priority: Minor
>
> Stack made a number of suggestions for improvements in the code changes from HADOOP-2443:
> Here in HConnectionManager:
> +          scannerId = server.openScanner(
> +            metaLocation.getRegionInfo().getRegionName(),
> +            COLUMN_FAMILY_ARRAY, EMPTY_START_ROW, LATEST_TIMESTAMP,
> +            null);
> ... EMPTY_START_ROW will work but 'startRow' would be easier to read (It'd work too -
right?).
> Here:
> +      } while (startRow.compareTo(EMPTY_START_ROW) != 0);
> .. EMPTY_ROW or a new define, LAST_ROW, would have been more readable, don't you think?
> This 999... 'trick' should be done as a method - in HTableInfo? - since you do it twice:
> +    Text tableKey = new Text(tableName.toString() + ",,99999999999999");

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message