hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-2596) add SequenceFile.createWriter() method that takes block size as parameter
Date Fri, 18 Jan 2008 20:12:35 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-2596?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12560531#action_12560531

Hadoop QA commented on HADOOP-2596:

-1 overall.  Here are the results of testing the latest attachment 
against trunk revision r613115.

    @author +1.  The patch does not contain any @author tags.

    javadoc +1.  The javadoc tool did not generate any warning messages.

    javac +1.  The applied patch does not generate any new compiler warnings.

    findbugs +1.  The patch does not introduce any new Findbugs warnings.

    core tests -1.  The patch failed core unit tests.

    contrib tests +1.  The patch passed contrib unit tests.

Test results: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1640/testReport/
Findbugs warnings: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1640/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Checkstyle results: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1640/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://lucene.zones.apache.org:8080/hudson/job/Hadoop-Patch/1640/console

This message is automatically generated.

> add SequenceFile.createWriter() method that takes block size as parameter
> -------------------------------------------------------------------------
>                 Key: HADOOP-2596
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2596
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: io
>         Environment: all
>            Reporter: Alejandro Abdelnur
>            Assignee: Alejandro Abdelnur
>            Priority: Minor
>             Fix For: 0.16.0
>         Attachments: patch2596.txt
> Currently it is not possible to create a SequenceFile.Writer using a block size other
than the default.
> The createWriter() method should be overloaded with a signature receiving block size
as parameter should be added to the the SequenceFile class.
> With all the current signatures for this method there is a significant code duplication,
if possible the createWriter() methods  should be refactored to avoid such duplication.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message