hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arun C Murthy (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-2596) add SequenceFile.createWriter() method that takes block size as parameter
Date Sat, 19 Jan 2008 00:33:34 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-2596?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Arun C Murthy updated HADOOP-2596:
----------------------------------

    Status: Patch Available  (was: Open)

> add SequenceFile.createWriter() method that takes block size as parameter
> -------------------------------------------------------------------------
>
>                 Key: HADOOP-2596
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2596
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: io
>         Environment: all
>            Reporter: Alejandro Abdelnur
>            Assignee: Alejandro Abdelnur
>            Priority: Minor
>             Fix For: 0.16.0
>
>         Attachments: patch2596.txt
>
>
> Currently it is not possible to create a SequenceFile.Writer using a block size other
than the default.
> The createWriter() method should be overloaded with a signature receiving block size
as parameter should be added to the the SequenceFile class.
> With all the current signatures for this method there is a significant code duplication,
if possible the createWriter() methods  should be refactored to avoid such duplication.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message