hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Kellerman (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-2518) [hbase] Refactor HStore and internal (and related) classes into hbase.store subpackage
Date Thu, 03 Jan 2008 20:21:34 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-2518?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12555668#action_12555668
] 

Jim Kellerman commented on HADOOP-2518:
---------------------------------------

ACK! no please!

I am in the middle of rewriting all this stuff to change the file layout.

> [hbase] Refactor HStore and internal (and related) classes into hbase.store subpackage
> --------------------------------------------------------------------------------------
>
>                 Key: HADOOP-2518
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2518
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: contrib/hbase
>            Reporter: Bryan Duxbury
>            Assignee: Bryan Duxbury
>            Priority: Minor
>         Attachments: 2518.patch
>
>
> HStore, the class responsible for managing data storage for column families within a
region, is a very large class with more than a few internal classes. I propose moving HStore
and HStoreFile into the hbase.store subpackage, and then moving internal classes out of HStore
and into their own package-internal classes within the subpackage. This will make the code
much more readable and manageable. In addition, it will help to logically delineate which
classes are involved in managing a store.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message