hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arun C Murthy (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-2268) JobControl classes should use interfaces rather than implemenations
Date Fri, 21 Dec 2007 16:08:45 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-2268?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12553964

Arun C Murthy commented on HADOOP-2268:

bq. So this patch is getting cancelled for the fact that I removed two blank lines?
Uh no, this isn't about the blank lines, I agree they are improvements...

The issue is the indentation with this piece:
-  private static ArrayList<Job> toArrayList(Hashtable<String, Job> jobs) {
+ private static ArrayList<Job> toArrayList(Map<String, Job> jobs) {

Sure, it appears very minor, but we've been bitten before (HADOOP-1148) and we'd rather not
do that again... hope you understand.

bq. As for the bigger picture [...]

Yes, like I said, it was an attempt to get everyone to reconsider folks that what you had
done earlier is probably the only choice... nothing against the patch. I agree a minor improvement
is good enough, I'm pushing for bigger ones too - still hoping.

> JobControl classes should use interfaces rather than implemenations
> -------------------------------------------------------------------
>                 Key: HADOOP-2268
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2268
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: mapred
>    Affects Versions: 0.15.0
>            Reporter: Adrian Woodhead
>            Assignee: Adrian Woodhead
>            Priority: Minor
>             Fix For: 0.16.0
>         Attachments: HADOOP-2268-1.patch, HADOOP-2268-2.patch, HADOOP-2268-3.patch
> See HADOOP-2202 for background on this issue. Arun C. Murthy agrees that when possible
it is preferable to program against the interface rather than a concrete implementation (more
flexible, allows for changes of the implementation in future etc.) JobControl currently exposes
running, waiting, ready, successful and dependent jobs as ArrayList rather than List. I propose
to change this to List.
> I will code up a patch for this.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message