hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-544) Replace the job, tip and task ids with objects.
Date Fri, 07 Dec 2007 19:45:43 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-544?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Doug Cutting updated HADOOP-544:
--------------------------------

    Status: Open  (was: Patch Available)

Some comments:
- this incompatibly changes public APIs.  we should instead create new methods and deprecate
the old ones.
- Id, JobId, etc. are preferred to ID, JobID, etc.: acronyms are best capitalized as words
- JobId, etc. should probably be separate classes, not nested classes
- the new classes need javadoc


> Replace the job, tip and task ids with objects.
> -----------------------------------------------
>
>                 Key: HADOOP-544
>                 URL: https://issues.apache.org/jira/browse/HADOOP-544
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: mapred
>    Affects Versions: 0.6.2
>            Reporter: Owen O'Malley
>            Assignee: Enis Soztutar
>             Fix For: 0.16.0
>
>         Attachments: id_v1.patch, id_wip1.patch
>
>
> I think that it is silly to have tools parsing the strings that the framework builds
for task ids. I propose:
> class JobId implements Writable {
>    public int getJobId() {...}
> }
> class TaskId implements Writable {
>   public JobId getJobId(); 
>   public boolean isMap() { ... }
>   public int getTaskId() { ... }
> }
> class TaskAttemptId implements Writable {
>   public TaskId getTaskId();
>   public int getAttemptId();
> }
> each of the classes will have a toString() method that generates the current string.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message