hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrian Woodhead (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-2268) JobControl classes should use interfaces rather than implemenations
Date Mon, 03 Dec 2007 14:19:43 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-2268?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12547851
] 

Adrian Woodhead commented on HADOOP-2268:
-----------------------------------------

Understood.

I personally don't like the idea of dropping the "get" from those method names, it seems much
clearer to have that in the name. "readyJobs" could also mean "get the jobs ready" which is
confusing. 

Another option would be to leave those 3 methods returning ArrayList and I modify the patch
to just change the internal hashtables -> Maps and do the deprecating for dependingJobs
with the method renamed like discussed earlier. The code will be better than it was but you
will still have the implementation "leak" on those 3 methods.

> JobControl classes should use interfaces rather than implemenations
> -------------------------------------------------------------------
>
>                 Key: HADOOP-2268
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2268
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: mapred
>    Affects Versions: 0.15.0
>            Reporter: Adrian Woodhead
>            Assignee: Adrian Woodhead
>            Priority: Minor
>             Fix For: 0.16.0
>
>         Attachments: HADOOP-2268-1.patch, HADOOP-2268-2.patch
>
>
> See HADOOP-2202 for background on this issue. Arun C. Murthy agrees that when possible
it is preferable to program against the interface rather than a concrete implementation (more
flexible, allows for changes of the implementation in future etc.) JobControl currently exposes
running, waiting, ready, successful and dependent jobs as ArrayList rather than List. I propose
to change this to List.
> I will code up a patch for this.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message