hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-2271) chmod in ant package target fails
Date Fri, 23 Nov 2007 18:03:45 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-2271?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12545100

stack commented on HADOOP-2271:

Maybe just ubuntu?  I tried w/ 1.5 and 1.6.

[stack@aa0-000-12 hadoop-trunk]$ pwd/home/stack/long-path/long-path/long-path/long-path/long-path/hadoop-trunk
[stack@aa0-000-12 hadoop-trunk]$ ~/bin/ant/bin/ant clean package
 [copy] Copied 106 empty directories to 3 empty directories under /home/stack/long-path/long-path/long-path/long-path/long-path/hadoop-trunk/build/hadoop-0.16.0-dev/docs
    [copy] Copying 4 files to /home/stack/long-path/long-path/long-path/long-path/long-path/hadoop-trunk/build/hadoop-0.16.0-dev
    [copy] Copying 1200 files to /home/stack/long-path/long-path/long-path/long-path/long-path/hadoop-trunk/build/hadoop-0.16.0-dev/src
    [copy] Copying 1 file to /home/stack/long-path/long-path/long-path/long-path/long-path/hadoop-trunk/build/hadoop-0.16.0-devBUILD
SUCCESSFULTotal time: 43 seconds

> chmod in ant package target fails
> ---------------------------------
>                 Key: HADOOP-2271
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2271
>             Project: Hadoop
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.15.0
>            Reporter: Adrian Woodhead
>         Attachments: HADOOP-2271-1.patch
> If you checkout the trunk to a folder long than /tmp (in my case it is "/home/adrian/workspace/hadoop-trunk")
and you execute the command:
> ant clean package
> You get the following error:
> /home/adrian/workspace/hadoop-trunk/build.xml:730: Execute failed: java.io.IOException:
Cannot run program "chmod": java.io.IOException: error=7, Argument list too long
> I also tried this from the folder "/tmp/trunk" and the package target worked fine so
I imagine the argument list is becoming too long due to the folder being longer. A simple
fix for this should be to set the "parallel" attribute on chmod to false.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message