hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joydeep Sen Sarma (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-2009) configure script for compiling hadoop native doesn't set lzo lib name correctly
Date Tue, 09 Oct 2007 19:29:50 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-2009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12533463

Joydeep Sen Sarma commented on HADOOP-2009:

here's the log. i think that the error should be detected in configure and auto-configuration
should either fail outright or print a loud warning that compilation of native libs will not
work unless some steps are taken. It might take me some more time to test with .so

     [exec] if /bin/sh ../../../../../../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H
../../../../..  -I/usr/local/java/include -I/usr/local/java/include/linux -I/home/jssarma/fbproject\
s/hadoop-0.13.1/src/native/src  -g -Wall -fPIC -O2 -m64 -g -O2 -MT LzoCompressor.lo -MD -MP
-MF ".d\
eps/LzoCompressor.Tpo" -c -o LzoCompressor.lo /home/jssarma/fbprojects/hadoop-0.13.1/src/native/src\
/org/apache/hadoop/io/compress/lzo/LzoCompressor.c; \
     [exec] then mv -f ".deps/LzoCompressor.Tpo" ".deps/LzoCompressor.Plo"; else rm -f ".deps/LzoCo\
mpressor.Tpo"; exit 1; fi
     [exec]  gcc -DHAVE_CONFIG_H -I. -I/home/jssarma/fbprojects/hadoop-0.13.1/src/native/src/org/ap\
ache/hadoop/io/compress/lzo -I../../../../../../.. -I/usr/local/java/include -I/usr/local/java/incl\
ude/linux -I/home/jssarma/fbprojects/hadoop-0.13.1/src/native/src -g -Wall -fPIC -O2 -m64
-g -O2 -M\
T LzoCompressor.lo -MD -MP -MF .deps/LzoCompressor.Tpo -c /home/jssarma/fbprojects/hadoop-0.13.1/sr\
c/native/src/org/apache/hadoop/io/compress/lzo/LzoCompressor.c  -fPIC -DPIC -o .libs/LzoCompressor.\
     [exec] /home/jssarma/fbprojects/hadoop-0.13.1/src/native/src/org/apache/hadoop/io/compress/lzo\
/LzoCompressor.c: In function 'Java_org_apache_hadoop_io_compress_lzo_LzoCompressor_initIDs':
     [exec] /home/jssarma/fbprojects/hadoop-0.13.1/src/native/src/org/apache/hadoop/io/compress/lzo\
/LzoCompressor.c:116: error: syntax error before '/' token
     [exec] make[2]: Leaving directory `/home/jssarma/fbprojects/hadoop-0.13.1/build/native/Linux-a\
     [exec] make[2]: *** [LzoCompressor.lo] Error 1
     [exec] make[1]: Leaving directory `/home/jssarma/fbprojects/hadoop-0.13.1/build/native/Linux-a\
     [exec] make[1]: *** [all-recursive] Error 1
     [exec] make: *** [all] Error 2

/home/jssarma/fbprojects/hadoop-0.13.1/build.xml:285: exec returned: 2
        at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:591)
        at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:617)
        at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:452)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)

> configure script for compiling hadoop native doesn't set lzo lib name correctly
> -------------------------------------------------------------------------------
>                 Key: HADOOP-2009
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2009
>             Project: Hadoop
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.13.1
>         Environment: Fedora, amd64
>            Reporter: Joydeep Sen Sarma
>            Assignee: Arun C Murthy
> Looks like this was already reported (but not resolved on the the list): http://tinyurl.com/2rwu6x
> I would like to compile libhadoop on amd64/Fedora and everything seems kosher until I
hit this compile error:
>      [exec] /home/jssarma/fbprojects/hadoop-0.13.1/src/native/src/org/apache/hadoop/io/compress/lzo/LzoCompressor.c:116:
error: syntax error before ',' token
> the line in question is:
>     // Load liblzo2.so                                                              
>     liblzo2 = dlopen(HADOOP_LZO_LIBRARY, RTLD_LAZY | RTLD_GLOBAL);
> seems like this is being set by:
> configure:#define HADOOP_LZO_LIBRARY ${ac_cv_libname_lzo2}
> I tried executing the relevant part of configure by hand:
>   if test -z "`${CC} -o conftest conftest.c -llzo2 2>&1`"; then
>         if test ! -z "`which objdump`"; then
>       ac_cv_libname_lzo2="`objdump -p conftest | grep NEEDED | grep lzo2 | sed 's/\W*NEEDED\W*\(.*\)\W*$/\
> \"\1\"/'`"
> This is not working on my system, since:
> > objdump -p conftest | grep NEEDED                         
>   NEEDED      libc.so.6
> So that would explain the compile error. Editing the configure script manually for now

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message