hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raghu Angadi <rang...@yahoo-inc.com>
Subject Re: javax.net.SocketFactory
Date Thu, 11 Oct 2007 22:14:25 GMT

Looks like my eclipse used JRE_LIB for java library. While trying to add 
libraries [ Configure Build Path --> Libraries (tab) ], there was a note 
that said "JRE_LIB is deprecated use JRE instead".. So removed JRE_LIB 
from "Referenced Libraries" and added jdk6 from [ Configure Build path 
--> Libraries --> Add Library --> JRE System Library ]. Now there are no 
errors (still it can't find source or there is no source).

I don't know how JRE_LIB got set initially.

Raghu.

Christophe Taton wrote:
> When I mean building in Eclipse, I mean letting Eclipse rebuild its own
> class files for editing purpose :) Sometimes Eclipse gets a bit lost...
> I checked and the javax.net.SocketFactory class is found in my
> $JAVA_HOME/jre/lib/jsse.jar
> 
> Chris
> 
> Raghu Angadi wrote:
>> I am not actually building using eclipse. But it shows an error for
>> this since it can not resolve it. I am wondering what might be missing
>> in my config that causes the error. I am using jdk6 for ("Installed
>> JREs" under eclipse).
>>
>> Can you find where you eclipse find this class?
>>
>> Raghu.
>>
>> Christophe Taton wrote:
>>> Hi Raghu,
>>> This should actually build on your Eclipse. I tried again on mine and
>>> everything's alright, with jdk5 and with jdk6 compliance.
>>> Can you try to clean the project and let Eclipse rebuild it again?
>>> Chris
>>>
>>> On 10/11/07, Raghu Angadi <rangadi@yahoo-inc.com> wrote:
>>>> On trunk compilation goes well but my eclipse can't find
>>>> 'javax.net.SocketFactory' (imported in DFSClient.java). How can I avoid
>>>> this error in eclipse?
>>>>
>>>> thanks,
>>>> Raghu.


Mime
View raw message