hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arun C Murthy (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-1981) Need to document the controls for sorting and grouping into the reduce
Date Tue, 23 Oct 2007 11:37:52 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-1981?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12536967
] 

Arun C Murthy commented on HADOOP-1981:
---------------------------------------

bq. Both methods desperately need better names. 

+1

I completely agree, unless anyone objects I'll roll this into HADOOP-2046 since the changed
names better reflect what they are meant to do.

Oh, btw I'd go for {{setKeyGroupingComparator}} and {{setKeyEquivalenceComparator}}... *smile*

> Need to document the controls for sorting and grouping into the reduce
> ----------------------------------------------------------------------
>
>                 Key: HADOOP-1981
>                 URL: https://issues.apache.org/jira/browse/HADOOP-1981
>             Project: Hadoop
>          Issue Type: Task
>          Components: mapred
>            Reporter: Owen O'Malley
>            Assignee: Arun C Murthy
>
> The JavaDoc for the Reducer should document how to control the sort order of keys and
values via the JobConf methods:
> {code}
>   setOutputKeyComparatorClass
>   setOutputValueGroupingComparator
> {code}
> Both methods desperately need better names. (I'd vote for setKeySortingComparator and
setKeyGroupingComparator.)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message