hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Bieniosek <mich...@powerset.com>
Subject binary backwards-incompatibility for 0.14.0
Date Thu, 16 Aug 2007 21:54:03 GMT
I've noticed a strange linking problem upgrading from previous hadoop
versions: the elimination of the JobClient(Configuration) constructor that
is backwards-compatible for source, but not for binaries.  That is to say, I
built my job jar with hadoop-0.12.3; when I upgrade I have to do a full
rebuild (otherwise I get a nasty linking error) but don't have to change the
source.

-Michael

On 8/15/07 2:52 PM, "Doug Cutting" <cutting@apache.org> wrote:

> I've created a candidate build for Hadoop 0.14.0.
> 
>    http://people.apache.org/~cutting/hadoop-0.14.0-candidate-0/
> 
> Should we release this?
> 
> Doug


Mime
View raw message