hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nigel Daley <nda...@yahoo-inc.com>
Subject Re: [jira] Commented: (HADOOP-1668) add INCOMPATIBLE CHANGES section to CHANGES.txt for Hadoop 0.14
Date Fri, 03 Aug 2007 17:40:06 GMT
Any other know incompatibilities (API, protocol, layout) between 0.13  
and 0.14?
Owen?  Dhruba?  Others?

On Jul 31, 2007, at 5:13 PM, Raghu Angadi (JIRA) wrote:

>
>     [ https://issues.apache.org/jira/browse/HADOOP-1668? 
> page=com.atlassian.jira.plugin.system.issuetabpanels:comment- 
> tabpanel#action_12516833 ]
>
> Raghu Angadi commented on HADOOP-1668:
> --------------------------------------
>
> Incompatible changes in HADOOP-1134 :
>
>  -  dfs.block.size should be a  multiple of io.byte.per.checksum.  
> Otherwise new files can not be written. No changes to default config.
>  -  DFS layout version changed from -6 to -7. As with any layout  
> change, existing cluster need to be finalized before upgrading the  
> software and cluster should be started with upgrade option after  
> software upgrade.
>  - Datanode RPC protocol version changed from 7 to 8 (this may not  
> be considered incompatible).
>
> I will add a link to uprade guide for this upgrade.
>
>> add INCOMPATIBLE CHANGES section to CHANGES.txt for Hadoop 0.14
>> ---------------------------------------------------------------
>>
>>                 Key: HADOOP-1668
>>                 URL: https://issues.apache.org/jira/browse/ 
>> HADOOP-1668
>>             Project: Hadoop
>>          Issue Type: Bug
>>          Components: documentation
>>    Affects Versions: 0.14.0
>>            Reporter: Nigel Daley
>>            Assignee: Nigel Daley
>>            Priority: Blocker
>>             Fix For: 0.14.0
>>
>>
>> HADOOP-1134 and some other Jira's have introduced incompatible  
>> changes into Hadoop 0.14.  As per HADOOP-1667 the CHANGES.txt file  
>> will include sections for these kind of changes for Hadoop 0.15  
>> and beyond.  As a stop gap for 0.14, the CHANGES.txt file needs an  
>> INCOMPATIBLE CHANGES section.
>
> -- 
> This message is automatically generated by JIRA.
> -
> You can reply to this email to add a comment to the issue online.
>


Mime
View raw message