hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (HADOOP-1745) userlogs not showing up for new jobs
Date Tue, 21 Aug 2007 16:40:30 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-1745?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Owen O'Malley resolved HADOOP-1745.
-----------------------------------

    Resolution: Won't Fix
      Assignee: Owen O'Malley

In HADOOP-1553, I had to take out the user log split code because if anyone actually wrote
to stdout or stderr, it was causing a 10x slow down for the maps and reduces. (Seriously.
In the word count example, it was going from 6 seconds/map to 3 minutes/map. With the HADOOP-1553
patch, it goes back to 6 seconds.) If you want the logs immediately you need to set the mapred.userlog.purge.splits
to 0. Otherwise, it is using the tail program to keep the tail of the logs.

> userlogs not showing up for new jobs
> ------------------------------------
>
>                 Key: HADOOP-1745
>                 URL: https://issues.apache.org/jira/browse/HADOOP-1745
>             Project: Hadoop
>          Issue Type: Bug
>          Components: mapred
>    Affects Versions: 0.14.0
>            Reporter: Michael Bieniosek
>            Assignee: Owen O'Malley
>
> When I start a new hadoop job, the logs do not show up for a while.  If I check on the
filesystem, the file userlogs/$task/stdout is a regular file with size 0.
> This was supposed to be fixed in 0.14 by HADOOP-1524.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message