hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christophe Taton (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-1653) FSDirectory class code cleanup
Date Thu, 26 Jul 2007 01:54:31 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-1653?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12515474
] 

Christophe Taton commented on HADOOP-1653:
------------------------------------------

Ok, I replace UTF8 with Text.
Should I also remove its use in other log methods: logRename, logDelete and logSetReplication?


> FSDirectory class code cleanup
> ------------------------------
>
>                 Key: HADOOP-1653
>                 URL: https://issues.apache.org/jira/browse/HADOOP-1653
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: dfs
>    Affects Versions: 0.15.0
>            Reporter: Christophe Taton
>            Priority: Trivial
>         Attachments: fsdirectory-cleanup-20070725-1706.patch
>
>
>  - lets FSDirectory.INode become a static class, thus sparing one pointer per INode
>  - removes an unused constructor for FSDirectory.INode
>  - merges identical methods INode.getAbsoluteName() and INode.computeName() and optimizes
it using StringBuffer

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message