hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-1375) a simple parser for hbase.
Date Mon, 21 May 2007 18:34:16 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-1375?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12497536

stack commented on HADOOP-1375:

Some more comments Udanax:

+ Above I suggest that 'parser' is confusing to folks when what your work does is add a hbase
'shell'.  You should rename the 'parser' subpackage 'shell': i.e. classes should be in src/contrib/hbase/src/java/org/apache/hadoop/hbase/shell/HbaseParser.java
and not in src/contrib/hbase/src/java/org/apache/hadoop/hbase/parser/HbaseParser.java.  Also,
to align with how other classes in hbase package are named, this class should be HBaseParser,
not HbaseParser -- or rather, HBaseShell -- and the same for HbaseParser, etc.).

I tried the patch.

+ You should prettify the help message.  Its hard to read as is w/ irregular spacing.  
+ I would suggest that you use the verb 'create' instead of 'build' for table creation (to
match sql, especially since you use the sql 'drop' for the antithesis).   Or, at least make
create a synonym for 'build'.
+ Square brackets around arguments usually indicates optional arguments in unix usage.  Use
angle brackets or no brackets (as bash help seems to do).
+ Is the 'where....' clause optional when scanning?  Doesn't look to be going by the help
output.  If it is not, I'd suggest you make it so.  If it is absent, all rows should be returned.
+ I do not seem to be able to navigate using arrow keys (left or right to make corrections).
 Would be nice if I could also to use up and down arrows to replay previous inputs (In old
days with jython, this necessitated something like ReadLine: http://www.codezoo.com/pub/component/851?category=17.
 You might also check out how beanshell does it -- it seems to do a nice job of it)

Good stuff Udanax

> a simple parser for hbase.
> --------------------------
>                 Key: HADOOP-1375
>                 URL: https://issues.apache.org/jira/browse/HADOOP-1375
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: contrib/hbase
>         Environment: All environments 
>            Reporter: udanax
>         Assigned To: Jim Kellerman
>            Priority: Minor
>         Attachments: patch.txt, patch.txt, patch.txt, patch.txt, patch.txt
> this is a simple parser for hbase test.
> i just write it.
> you can use this syntax to create and set.
> {code}
> [# root@localhost] ./bin/hadoop jar ./build/hadoop-hbase org.apache.hadoop.hbase.parser.HbaseParser
> Hbase > help;
> blah blah...
> Hbase > build webtable columnfamilies('anchors', 'language') limit=3;
> Hbase > set webtable values('anchors:http://www.udanax.org/','opensource') where row="http://www.hadoop.co.kr";
> Hbase > scan webtable where row="http://www.hadoop.co.kr";
> blah blah...
> Hbase > set webtable values('language:kr','euc-kr') where row="http://www.hadoop.co.kr";
> Hbase > scan webtable where row="http://www.hadoop.co.kr" and column="language:kr";
> blah blah...
> Hbase > exit
> [# root@localhost] 
> {code}

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message