hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raghu Angadi (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-1155) Additional performance improvement to chooseTarget
Date Wed, 11 Apr 2007 00:33:32 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-1155?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12487963
] 

Raghu Angadi commented on HADOOP-1155:
--------------------------------------

> 2. optimize sortedByDistance by taking Sameer's suggestion in HADOOP-1073: 
I am looking at the patch, in the mean while, I think should change the name of 'sortByDistance()'
to something else, since it neither sorts the array nor uses distances any more.  But I can't
think of a good name.. suggestions are welcome.


> Additional performance improvement to chooseTarget
> --------------------------------------------------
>
>                 Key: HADOOP-1155
>                 URL: https://issues.apache.org/jira/browse/HADOOP-1155
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: dfs
>    Affects Versions: 0.12.2
>            Reporter: Hairong Kuang
>         Assigned To: Hairong Kuang
>             Fix For: 0.13.0
>
>         Attachments: rackMap.patch, rackMap1.patch, rackMap2.patch
>
>
> A few additional thoughts to improve the performance of chooseTarget:
> 1. Reduce the # of calls to getDistance in sortedByDistance
> 2. Improve the performance of getNode by adding a rack name to rack node map

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message