hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-1272) Extract InnerClasses from FSNamesystem into separate classes
Date Mon, 23 Apr 2007 18:19:15 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-1272?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12491014
] 

Doug Cutting commented on HADOOP-1272:
--------------------------------------


This seems like we're cluttering the package in order to de-clutter the 
file, not a great tradeoff.  I'd rather see this as a part of a package 
re-structuring.  Arguably HDFS should move into a set of packages under 
org.apache.hadoop.dfs, and these would go into the namenode sub-package. 
  If folks agree with that as the long-term plan, then:

- How would we name these after such a restructuring?  That's probably 
what we should name them now.  The above names are probably okay in that 
context, as package-private classes in the namenode package.

- Is there any reason not to restructure HDFS's packages now?  I can't 
think of any.  There shouldn't be any user code that calls HDFS code 
directly, should there?  So I don't think back-compatibility is an issue.

Doug




> Extract InnerClasses from FSNamesystem into separate classes
> ------------------------------------------------------------
>
>                 Key: HADOOP-1272
>                 URL: https://issues.apache.org/jira/browse/HADOOP-1272
>             Project: Hadoop
>          Issue Type: Bug
>          Components: dfs
>            Reporter: dhruba borthakur
>         Assigned To: dhruba borthakur
>         Attachments: innerclasses.patch
>
>
> This will make the code cleaner. Also, it leads itself to a cleaner and easily understandable
finer-grain locking model.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message