hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-1069) Rename Hadoop record I/O to Jute
Date Tue, 06 Mar 2007 19:17:24 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-1069?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12478526
] 

Doug Cutting commented on HADOOP-1069:
--------------------------------------

> What about 'beans' and 'swing'?

Beans is meant to be descriptive, via a pun: a unit of Java (coffee) is a bean.

Swing was originally a separate project that was grafted into the JVM and not renamed, probably
for back-compatibility.

But these are good examples of bad Java package names.  Thanks!



> Rename Hadoop record I/O to Jute
> --------------------------------
>
>                 Key: HADOOP-1069
>                 URL: https://issues.apache.org/jira/browse/HADOOP-1069
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: record
>    Affects Versions: 0.12.0
>         Environment: All
>            Reporter: Milind Bhandarkar
>         Assigned To: Milind Bhandarkar
>             Fix For: 0.13.0
>
>
> jute was the original name of the hadoop record i/o component. IMHO, it is easier to
pronounce, easier to remember and has already stuck among its users. This renaming should
be done while there isn't a large codebase using jute, otherwise it will be very difficult
later. rcc will be renamed jrc (jute record compiler).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message