hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "eric baldeschwieler (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-1069) Rename Hadoop record I/O to Jute
Date Wed, 07 Mar 2007 19:15:24 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-1069?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12478857
] 

eric baldeschwieler commented on HADOOP-1069:
---------------------------------------------

So let's get some proposals for good names?

Our goal is to assign "Jute" a name that is short, memorable and works with our goals of defining
a top-level package that can be used in many contexts.  Doesn't seem optimal.  "Jute" seems
to do a better job.

Open to other suggestions.

> Rename Hadoop record I/O to Jute
> --------------------------------
>
>                 Key: HADOOP-1069
>                 URL: https://issues.apache.org/jira/browse/HADOOP-1069
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: record
>    Affects Versions: 0.12.0
>         Environment: All
>            Reporter: Milind Bhandarkar
>         Assigned To: Milind Bhandarkar
>             Fix For: 0.13.0
>
>
> jute was the original name of the hadoop record i/o component. IMHO, it is easier to
pronounce, easier to remember and has already stuck among its users. This renaming should
be done while there isn't a large codebase using jute, otherwise it will be very difficult
later. rcc will be renamed jrc (jute record compiler).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message