hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom White (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-1096) Rename InputArchive and OutputArchive and make them public
Date Sat, 17 Mar 2007 08:44:09 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-1096?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Tom White updated HADOOP-1096:

    Resolution: Fixed
        Status: Resolved  (was: Patch Available)

I've just committed this. Thanks Milind!

> Rename InputArchive and OutputArchive and make them public
> ----------------------------------------------------------
>                 Key: HADOOP-1096
>                 URL: https://issues.apache.org/jira/browse/HADOOP-1096
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: record
>    Affects Versions: 0.12.0
>         Environment: All
>            Reporter: Milind Bhandarkar
>         Assigned To: Milind Bhandarkar
>             Fix For: 0.12.1
>         Attachments: jute-patch.txt
> Currently hadoop.record.RecordReader and RecordWriter act as factories for various InputArchive
and OutputArchive recently. In the original design, this was done in order to have tight control
over various serialization formats. This has proven to be counterproductive. For wider usage
of record I/O one should be able to use their own serialization formats. The proposed changes
make it possible. They are as follows: 
> 1. Eliminate current record.RecordReader and record.RecordWriter. 
> 2. rename InputArchive as RecordInput, and OutputArchive as RecordOutput. 
> 3. rename various archives accordingly. e..g. BinaryInputArchive -> BinaryRecordInput

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message