hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Shvachko (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-1026) UnderReplicationBlocks should use generic types
Date Sat, 17 Feb 2007 21:38:05 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-1026?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12473961
] 

Konstantin Shvachko commented on HADOOP-1026:
---------------------------------------------

Clarifying on (2):
The class name is somewhat misleading because it does not describe blocks, which are currently
being replicated,
 that is under replication, but rather blocks that have low replication factor, that is under-replicated.


> UnderReplicationBlocks should use generic types
> -----------------------------------------------
>
>                 Key: HADOOP-1026
>                 URL: https://issues.apache.org/jira/browse/HADOOP-1026
>             Project: Hadoop
>          Issue Type: Bug
>          Components: dfs
>            Reporter: Konstantin Shvachko
>            Priority: Minor
>
> 1. HADOOP-659 introduced new class UnderReplicationBlocks, and
> two new warnings about use of generic types
>         TreeSet<Block>[] priorityQueues = new TreeSet[LEVEL];
>         Iterator<Block>[] iterator = new Iterator[LEVEL];
> should resp. read
>         TreeSet<Block>[] priorityQueues = new TreeSet<Block>[LEVEL];
>         Iterator<Block>[] iterator = new Iterator<Block>[LEVEL];
> 2. I'd rename class UnderReplicationBlocks to UnderReplicatedBlocks while it is still
internal.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message