hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-948) Coding style issues
Date Tue, 06 Feb 2007 06:46:05 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-948?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12470459
] 

Owen O'Malley commented on HADOOP-948:
--------------------------------------

Irrational fear of a second return has lead to lots of unnecessary code branches, in my experience.
I'd rather see a return early in a function that a nested if branch that includes the rest
of the body of the function.

> Coding style issues 
> --------------------
>
>                 Key: HADOOP-948
>                 URL: https://issues.apache.org/jira/browse/HADOOP-948
>             Project: Hadoop
>          Issue Type: Bug
>          Components: metrics
>            Reporter: David Bowen
>            Priority: Minor
>         Attachments: hadoop-948.patch
>
>
> I would like to recommend some mainly stylistic changes in the recent fix of http://issues.apache.org/jira/browse/HADOOP-886.
 The file in question is CodeFactory.java, and the reasons for the changes are:
>    * It is generally preferable to avoid multiple return statements.
>    * It is nearly always preferable to use curly braces and a newline after an if (condition).
>    * There's no benefit to doing the hash lookup twice in the common case (by calling
contains and then get).
> (1) and (2) are commonly found in Java coding style guidelines as they make the code
more readable. 
> I'll attach the fix shortly.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message