hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-1007) Names used for map, reduce, and shuffle metrics should be unique
Date Fri, 09 Feb 2007 23:35:06 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-1007?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Doug Cutting updated HADOOP-1007:
---------------------------------

    Resolution: Fixed
        Status: Resolved  (was: Patch Available)

I just committed this.  Thanks, Nigel!

> Names used for map, reduce, and shuffle metrics should be unique
> ----------------------------------------------------------------
>
>                 Key: HADOOP-1007
>                 URL: https://issues.apache.org/jira/browse/HADOOP-1007
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: metrics
>    Affects Versions: 0.12.0
>            Reporter: Nigel Daley
>         Assigned To: Nigel Daley
>            Priority: Trivial
>             Fix For: 0.12.0
>
>         Attachments: HADOOP-1007.patch
>
>
> The names used for map, reduce, and shuffle metrics currently overlap:
> Map metrics:
>   input_bytes 
>   input_records 
>   output_bytes 
>   output_records 
> Recduce metrics:
>    input_records 
>    output_records 
> Shuffle metrics:
>    input_bytes 
> I propose that the metric names be unique:
>   map_input_bytes 
>   map_input_records 
>   map_output_bytes 
>   map_output_records 
>   shuffle_input_bytes 
>   reduce_input_records 
>   reduce_output_records

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message