hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "dhruba borthakur (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-709) streaming job with Control characters in the command causes runtime exception in the job tracker
Date Sat, 11 Nov 2006 01:51:38 GMT
    [ http://issues.apache.org/jira/browse/HADOOP-709?page=comments#action_12448922 ] 
dhruba borthakur commented on HADOOP-709:

Another sun issue:

Our streaming code creates an XML file for the job. This file as an entry of the form:

One option would be that user-input be encoded in Base64 before being XML-ised. This is necessary
to support non-ascii user-input.

> streaming job with Control characters in the command causes runtime exception in the
job tracker
> ------------------------------------------------------------------------------------------------
>                 Key: HADOOP-709
>                 URL: http://issues.apache.org/jira/browse/HADOOP-709
>             Project: Hadoop
>          Issue Type: Bug
>          Components: contrib/streaming
>            Reporter: dhruba borthakur
>         Assigned To: dhruba borthakur
> I run a streaming job with a Ctrl-A character in the command line option as follows:
> $HSTREAMING -mapper "/bin/sort -t'^A'" -input "input/*" -output output
> It causes a exeception as listed below. If i run the same command without the Ctrl-A
character the command completes successfully.
> Exception in thread "main" org.apache.hadoop.ipc.RemoteException: java.io.IOException:
java.lang.RuntimeException: org.xml.sax.SAXParseException: Character reference "&#1" is
an invalid XML character.
>         at org.apache.hadoop.conf.Configuration.loadResource(Configuration.java:551)
>         at org.apache.hadoop.conf.Configuration.loadResources(Configuration.java:472)
>         at org.apache.hadoop.conf.Configuration.getProps(Configuration.java:453)
>         at org.apache.hadoop.conf.Configuration.get(Configuration.java:201)
>         at org.apache.hadoop.mapred.JobConf.getUser(JobConf.java:175)
>         at org.apache.hadoop.mapred.JobInProgress.<init>(JobInProgress.java:88)
>         at org.apache.hadoop.mapred.JobTracker.submitJob(JobTracker.java:1016)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:585)
>         at org.apache.hadoop.ipc.RPC$Server.call(RPC.java:337)
>         at org.apache.hadoop.ipc.Server$Handler.run(Server.java:514)
>         at org.apache.hadoop.ipc.Client$Connection.run(Client.java:248)

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message