hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Reed (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-602) Remove Lucene dependency
Date Fri, 13 Oct 2006 13:58:40 GMT
    [ http://issues.apache.org/jira/browse/HADOOP-602?page=comments#action_12442030 ] 
            
Benjamin Reed commented on HADOOP-602:
--------------------------------------

Since we have switched to 1.5. Can we use java.util.PriorityQueue?

> Remove Lucene dependency
> ------------------------
>
>                 Key: HADOOP-602
>                 URL: http://issues.apache.org/jira/browse/HADOOP-602
>             Project: Hadoop
>          Issue Type: Improvement
>    Affects Versions: 0.8.0
>            Reporter: Andrzej Bialecki 
>         Assigned To: Andrzej Bialecki 
>             Fix For: 0.8.0
>
>
> Hadoop uses just a single class from Lucene, namely the PriorityQueue. I propose to remove
this dependency by copying this class into org.apache.hadoop.util.PriorityQueue and removing
lucene-core.jar from dependencies.
> Removing this dependency makes it easier to run map-reduce applications that use different
versions of Lucene.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message