hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] Created: (HADOOP-544) Replace the job, tip and task ids with objects.
Date Tue, 19 Sep 2006 05:47:22 GMT
Replace the job, tip and task ids with objects.

                 Key: HADOOP-544
                 URL: http://issues.apache.org/jira/browse/HADOOP-544
             Project: Hadoop
          Issue Type: Improvement
    Affects Versions: 0.6.2
            Reporter: Owen O'Malley
         Assigned To: Owen O'Malley

I think that it is silly to have tools parsing the strings that the framework builds for task
ids. I propose:

class JobId implements Writable {
  private int;

class TaskId extends JobId { 
  private boolean isMap;
  private int taskId;

class TaskAttemptId extends TaskId {
  private int attemptId;

each of the classes will have a toString() method that generates the current string.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message