hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sameer Paranjpye (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-230) improve syntax of the hadoop dfs command
Date Thu, 28 Sep 2006 20:26:51 GMT
     [ http://issues.apache.org/jira/browse/HADOOP-230?page=all ]

Sameer Paranjpye updated HADOOP-230:
------------------------------------

    Component/s: dfs

> improve syntax of the hadoop dfs command
> ----------------------------------------
>
>                 Key: HADOOP-230
>                 URL: http://issues.apache.org/jira/browse/HADOOP-230
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: dfs
>            Reporter: Yoram Arnon
>            Priority: Minor
>
> the hadoop dfs syntax (hadoop dfs -option value -cmd arg) is clunky: options must appear
before the command, the command looks like just another option.
> I propose a more standard syntax:
> 1. the command (ls, mv, du etc.) always comes first
> 2. no '-' for the command
> 3. options may appear anywhere, including between the command and its arguments
> allowed syntax would be:
> hadoop dfs ls -dfs <dfs> /path
> hadoop dfs ls /path -dfs <dfs>
> other commands may benefit from a similar syntax change:
> hadoop job [-status] job_0002 -jt <jt>
> etc.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message