hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Cutting (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-398) refactor the mapred package into small pieces
Date Tue, 01 Aug 2006 18:24:14 GMT
    [ http://issues.apache.org/jira/browse/HADOOP-398?page=comments#action_12424970 ] 
Doug Cutting commented on HADOOP-398:


I would name the "utils" package "common" or something instead, since "util" might imply it's
for users.

Should we also move the input & output format implementations to an "io" package, or to
the "lib" package?

> refactor the mapred package into small pieces
> ---------------------------------------------
>                 Key: HADOOP-398
>                 URL: http://issues.apache.org/jira/browse/HADOOP-398
>             Project: Hadoop
>          Issue Type: Improvement
>          Components: mapred
>    Affects Versions: 0.4.0
>            Reporter: Owen O'Malley
>         Assigned To: Owen O'Malley
> The mapred package has gotten too big, so I propose changing it to split it into parts.
> I propose the following splits:
> org.apache.hadoop.mapred = client API
> org.apache.hadoop.mapred.task = code for task tracker
> org.apache.hadoop.mapred.job = code for job tracker
> org.apache.hadoop.mapred.utils = non public code that is shared between the servers
> Does anyone have any other divisions that would help?
> I would make the classes sent through RPC public classes in the server's package.
> Thoughts?

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message