hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-207) Patch to HADOOP-96 uses long deprecated call
Date Fri, 12 May 2006 20:16:11 GMT
    [ http://issues.apache.org/jira/browse/HADOOP-207?page=comments#action_12383267 ] 

Owen O'Malley commented on HADOOP-207:
--------------------------------------

Assuming you have the trivial program:

public class test {
  public static void main(String[] args) {
    System.out.println("Home is " + System.getenv("HOME"));
  }
}

Compiling under 1.5 produces no warnings.
Compiling under 1.4.2 produces a depreciated warning for getenv.

Running either the 1.5 or 1.4.2 class file under jvm 1.5 works fine.
Running the 1.4 binary under the jvm 1.4.2 throws:
Exception in thread "main" java.lang.Error: getenv no longer supported, use properties and
-D instead: HOME
        at java.lang.System.getenv(System.java:691)
        at test.main(test.java:3)


> Patch to HADOOP-96 uses long deprecated call
> --------------------------------------------
>
>          Key: HADOOP-207
>          URL: http://issues.apache.org/jira/browse/HADOOP-207
>      Project: Hadoop
>         Type: Bug

>     Versions: 0.2
>     Reporter: Bryan Pendleton
>     Assignee: Hairong Kuang
>     Priority: Critical
>      Fix For: 0.2.1
>  Attachments: logging.patch, logging.patch
>
> System.getenv() was deprecated in Java 1.4. My mixed Java 1.4/Java 1.5 cluster won't
start up with this code in place. Should probably change the scripts to pass the necessary
environment variables in using -D or explicit arguments.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message