hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Ritchie <jritc...@netwurklabs.com>
Subject Re: hadoop build fails in eclipse with last version of build.xml
Date Mon, 13 Feb 2006 17:15:06 GMT
Konstantin,

The -uriroot option is getting its base directory from where you started 
eclipse from I'm thinking.

I used netbeans from time to time and tried to build SVN Hadoop and was 
getting this error. 

After changing the -uriroot to an absolute path it worked.  So I 
defaulted back to the original build.xml closed out Netbeans and 
restarted it in the SVN trunk directory.  In your case I would have 
started it in the C:\work\nutch-0.7.1\Hadoop directory.  The ant task 
completed with no problems.

You have 2 options.

1.  Hard code the path in the build.xml file.
2. For ease of starting eclipse under windows.  Copy the shortcut to say 
your desktop.  'Right-click' 'properties' and change the 'start in' to 
c:\work\nutch-0.7.1\Hadoop

Now the question I have is why is that the only task that has a problem 
with relative directories?  Anyone?

Jeff.

Konstantin Shvachko wrote:

> I am compiling hadoop under eclipse, and receiving a JasperException.
> I understand this is some how related to transition from jspc to jasper,
> since before the last update everything worked fine.
> Anybody having the same problem?
> Do I need to do something to get jasper work properly?
>
> Here is the exact listing
>
> ----------------------------------------------------------
> Buildfile: C:\Work\nutch-0.7.1\Hadoop\build.xml
>
> init:
>
> compile:
>
> BUILD FAILED
> C:\Work\nutch-0.7.1\Hadoop\build.xml:109: 
> org.apache.jasper.JasperException: The -uriroot option must specify a 
> pre-existing directory
>
> Total time: 1 second
> ----------------------------------------------------------
>
> Thanks,
>
> Konstantin
>


Mime
View raw message