hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bryan A. Pendleton" ...@geekdom.net>
Subject Re: svn commit: r376366 - in /lucene/hadoop/trunk: build.xml src/webapps/jobtracker/ src/webapps/mapred/
Date Sun, 12 Feb 2006 18:56:11 GMT
I had to wrangle a few other details out to make things really be
independent of my running environment, but, no, it didn't work.

I did the svn checkout into a fresh directory. I ran ant using the
freshly-downloaded ant from apache, the same version you show (and the same
version that debian installed, mangled or not). Then I ran ant. I had to fix
things up because there's not equivalent of hadoop-site.xml for environments
and slaves - why use a directory-dependent set of configuration files, but
~/.slaves by default? Anyway, once I got JAVA_HOME fixed up and started a
single set of daemons, I still get the 404 error.

Actually, I think I'll go file a feature request to this effect, but it'd be
nice if hadoop/nutch specific environment variables were stored in someplace
in conf, as well. Possibly have an easy way of having a different list of
datanodes and tasknodes, too, since there're different resource constraints
on those, and many minght have a similar situation to the one I'm
developing, where datanodes can be run far more widely than tasknodes.

On 2/10/06, Doug Cutting <cutting@apache.org> wrote:
>
> Bryan A. Pendleton wrote:
> > When I use the latest build.xml, the jasper task doesn't run.
> >
> > Is there a missing library that should be available to make this work
> for
> > ant? I'm using a debian-installed ant, with the ant-optional package
> also
> > installed. After a default "ant" build, there are no jsps in
> build/webapps.
> > The  "compile:" ant job doesn't mention a jsp-compile task, either, all
> of
> > the lines of output are prefixed with "[javac]". Hitting
>
> I strongly recommend installing ant from Apache.  I've seen strange
> problems before with the debian install.  My ant shows:
>
> ant -version
> Apache Ant version 1.6.5 compiled on June 2 2005
>
> Try the following:
>
> svn co https://svn.apache.org/repos/asf/lucene/hadoop/trunk hadoop
> cd hadoop
> ant
> .... copy attached hadoop-site.xml to conf ...
> bin/start-all.sh
> wget -O - http://localhost:50030/
>
> Does that work for you?
>
> Doug
>
>
>


--
Bryan A. Pendleton
Ph: (877) geek-1-bp
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message