hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bryan A. Pendleton" ...@geekdom.net>
Subject Re: can not start jobtracker
Date Thu, 09 Feb 2006 20:00:31 GMT
Thank you, yes, that fixes the problem. I'm able to run my jobs under hadoop
now, instead of the old nutch with mapred.

On 2/9/06, Marko Bauhardt <mb@media-style.com> wrote:
>
> Ok, i think i found a solution. If i copy the xerces jars from nutch/
> lib (xerces-2_6_2-apis.jar and xerces-2_6_2.jar) into hadoop/lib, the
> jobtracker starts successfully.
>
> Marko
>
>
> Am 08.02.2006 um 19:43 schrieb Marko Bauhardt:
>
> > Hi,
> > i checkout the latest sources an try to start the jobtracker and
> > get the following exception.
> >
> >
> > org.xml.sax.SAXParseException: Elementtyp "web-app" ist nicht
> > deklariert.
> >       at org.apache.crimson.parser.Parser2.error(Parser2.java:3354)
> >       at org.apache.crimson.parser.Parser2.maybeElement(Parser2.java
> :1502)
> >       at org.apache.crimson.parser.Parser2.parseInternal (Parser2.java
> :667)
> >       at org.apache.crimson.parser.Parser2.parse(Parser2.java:337)
> >       at org.apache.crimson.parser.XMLReaderImpl.parse
> > (XMLReaderImpl.java:448)
> >       at javax.xml.parsers.SAXParser.parse (SAXParser.java:345)
> >       at org.mortbay.xml.XmlParser.parse(XmlParser.java:216)
> >       at org.mortbay.xml.XmlParser.parse(XmlParser.java:234)
> >       at org.mortbay.jetty.servlet.XMLConfiguration.configureDefaults
> > (XMLConfiguration.java:159)
> >       at
> > org.mortbay.jetty.servlet.WebApplicationContext.configureDefaults
> > (WebApplicationContext.java:414)
> >       at org.mortbay.jetty.servlet.WebApplicationContext.doStart
> > (WebApplicationContext.java:463)
> >       at org.mortbay.util.Container.start(Container.java:72)
> >       at org.mortbay.http.HttpServer.doStart(HttpServer.java:753)
> >       at org.mortbay.util.Container.start (Container.java:72)
> >       at org.apache.hadoop.mapred.JobTrackerInfoServer$HTTPStarter.run
> > (JobTrackerInfoServer.java:87)
> >       at java.lang.Thread.run(Thread.java:552)
> >
> > (Sounds like a missed or invalid web.xml?)
> >
> > What am i doing wrong?
> >
> > Thanks for any help.
> >
> > Marko
> >
> >
>
>


--
Bryan A. Pendleton
Ph: (877) geek-1-bp
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message