hadoop-common-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ka...@apache.org
Subject svn commit: r1581118 - in /hadoop/common/branches/branch-2.4/hadoop-common-project/hadoop-common: CHANGES.txt src/site/apt/Compatibility.apt.vm
Date Mon, 24 Mar 2014 23:27:43 GMT
Author: kasha
Date: Mon Mar 24 23:27:42 2014
New Revision: 1581118

URL: http://svn.apache.org/r1581118
Log:
HADOOP-10423. Clarify compatibility policy document for combination of new client and old
server. (Chris Nauroth via kasha)

Modified:
    hadoop/common/branches/branch-2.4/hadoop-common-project/hadoop-common/CHANGES.txt
    hadoop/common/branches/branch-2.4/hadoop-common-project/hadoop-common/src/site/apt/Compatibility.apt.vm

Modified: hadoop/common/branches/branch-2.4/hadoop-common-project/hadoop-common/CHANGES.txt
URL: http://svn.apache.org/viewvc/hadoop/common/branches/branch-2.4/hadoop-common-project/hadoop-common/CHANGES.txt?rev=1581118&r1=1581117&r2=1581118&view=diff
==============================================================================
--- hadoop/common/branches/branch-2.4/hadoop-common-project/hadoop-common/CHANGES.txt (original)
+++ hadoop/common/branches/branch-2.4/hadoop-common-project/hadoop-common/CHANGES.txt Mon
Mar 24 23:27:42 2014
@@ -59,6 +59,9 @@ Release 2.4.0 - UNRELEASED
     HADOOP-10015. UserGroupInformation prints out excessive warnings.
     (Nicolas Liochon via szetszwo)
 
+    HADOOP-10423. Clarify compatibility policy document for combination of 
+    new client and old server. (Chris Nauroth via kasha)
+
   OPTIMIZATIONS
 
   BUG FIXES

Modified: hadoop/common/branches/branch-2.4/hadoop-common-project/hadoop-common/src/site/apt/Compatibility.apt.vm
URL: http://svn.apache.org/viewvc/hadoop/common/branches/branch-2.4/hadoop-common-project/hadoop-common/src/site/apt/Compatibility.apt.vm?rev=1581118&r1=1581117&r2=1581118&view=diff
==============================================================================
--- hadoop/common/branches/branch-2.4/hadoop-common-project/hadoop-common/src/site/apt/Compatibility.apt.vm
(original)
+++ hadoop/common/branches/branch-2.4/hadoop-common-project/hadoop-common/src/site/apt/Compatibility.apt.vm
Mon Mar 24 23:27:42 2014
@@ -124,6 +124,15 @@ hand-in-hand to address this.
     (cluster) to a later version (or vice versa).  For example, a
     Hadoop 2.1.0 client talking to a Hadoop 2.3.0 cluster.
 
+    * Client-Server compatibility is also required to allow users to upgrade the
+    client before upgrading the server (cluster).  For example, a Hadoop 2.4.0
+    client talking to a Hadoop 2.3.0 cluster.  This allows deployment of
+    client-side bug fixes ahead of full cluster upgrades.  Note that new cluster
+    features invoked by new client APIs or shell commands will not be usable.
+    YARN applications that attempt to use new APIs (including new fields in data
+    structures) that have not yet deployed to the cluster can expect link
+    exceptions.
+
     * Client-Server compatibility is also required to allow upgrading
     individual components without upgrading others. For example,
     upgrade HDFS from version 2.1.0 to 2.2.0 without upgrading MapReduce.



Mime
View raw message