hadoop-common-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Hadoop Wiki] Update of "EclipseEnvironment" by KenKrugler
Date Fri, 29 May 2009 17:03:44 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Hadoop Wiki" for change notification.

The following page has been changed by KenKrugler:
http://wiki.apache.org/hadoop/EclipseEnvironment

The comment on the change is:
Added 1.6 notes & missing compile-core-test Ant target

------------------------------------------------------------------------------
  
   1. Set up an `ANT_HOME` Classpath Variable in Eclipse Preferences. This is a global Eclipse
setting so you only need to do this once.
   1. Checkout Hadoop.
-  1. Run the ''eclipse-files'' ant target (right click build.xml, choose run as Ant Build,
click "sort targets", and choose eclipse-files target)
+  1. Run the ''eclipse-files'' and ''compile-core-test'' ant targets (right click build.xml,
choose Run As > Ant Build..., click "sort targets", and check the eclipse-files and compile-core-test
targets). If you can't click the Run button because of an error that says your .class file
version is incompatible with 1.6, then you'll need to click the JRE tab and pick a 1.6-compatible
JRE.
   1. Refresh the Eclipse project.  (Hit F5 or right-click on the project, and choose "Refresh")
+  1. If your default Eclipse JRE is not 1.6, go to Project > Properties > Java Build
Path > Libraries, select the JRE System Library, click Edit, and select a 1.6 or later
JRE that's installed on your system. You may also want to set the Java Compiler's JDK Compliance
by going to Project > Properties > Java Compiler, check the "Enable project specific
settings", and select 6.0 for the Compiler compliance level.
-  1. Ensure that the Java version used matches the version of the project (currently 1.6
is used). This could be selected for the project by going to Project > Preferences >
Builders > Hadoop_Ant_Builders. Go to JRE tab and select an appropriate Java version.
+  1. Ensure that the Java version used matches the version of the project (currently 1.6
is used). This could be selected for the project by going to Project > Properties >
Builders > Hadoop_Ant_Builders. Go to JRE tab and select an appropriate Java version.
   1. Select `Project` | `Build Project`.
  
  

Mime
View raw message