hadoop-common-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Hadoop Wiki] Trivial Update of "Hbase/FAQ" by stack
Date Mon, 22 Sep 2008 00:28:39 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Hadoop Wiki" for change notification.

The following page has been changed by stack:
http://wiki.apache.org/hadoop/Hbase/FAQ

The comment on the change is:
Added FAQ on version numbering

------------------------------------------------------------------------------
   1. [#15 Can I safely move the master from node A to node B?]
   1. [#16 Can I safely move the hbase rootdir in hdfs?]
   1. [#17 Can HBase development be done on windows?]
+  1. [#18 Please explain HBase version numbering?]
-  1. [#18 What version of Hadoop do I need to run HBase?]
+  1. [#19 What version of Hadoop do I need to run HBase?]
  
  
  == Answers ==
@@ -152, +153 @@

  
  See the [http://hadoop.apache.org/core/docs/current/quickstart.html quickstart page] for
Hadoop. The requirements for developing HBase on Windows is the same as for Hadoop.
  
+ 
+ '''18 [[Anchor(18)]] Please explain HBase version numbering?'''
+ 
+ Originally HBase lived under src/contrib in Hadoop Core.  The HBase version was that of
the hosting Hadoop.  The last HBase version that bundled under contrib was part of Hadoop
0.16.1 (March of 2008).
+ 
+ The first HBase Hadoop subproject release was versioned 0.1.0.  Subsequent releases went
at least as far as 0.2.1 (September 2008).
+ 
+ In August of 2008, consensus had it that since HBase depends on a particular Hadoop Core
version, the HBase major+minor versions would from now on mirror that of the Hadoop Core version
HBase depends on.  The first HBase release to take on this new versioning regimine was 0.18.0
HBase; HBase 0.18.0 depends on Hadoop 0.18.x.
+ 
+ Sorry for any confusion caused.
+ 
- '''18 [[Anchor(18)]] What version of Hadoop do I need to run HBase?'''
+ '''19 [[Anchor(19)]] What version of Hadoop do I need to run HBase?'''
  
  Different versions of HBase require different versions of Hadoop.  Consult the table below
to find which version of Hadoop you will need:
  

Mime
View raw message