hadoop-common-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Lucene-hadoop Wiki] Update of "Hbase/HbaseRest" by BryanDuxbury
Date Thu, 15 Nov 2007 20:05:37 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Lucene-hadoop Wiki" for change notification.

The following page has been changed by BryanDuxbury:

  ~- Bryan comment: Unforunately I don't think there is any good HTTP verb for this operation.
DELETEing /current is about as good as POST/PUTing /next. With the DELETE approach, there
is one less resource, though. -~
  ~-''St.Ack comment 11/15/2007: Can you explain 'one less resource'?  (I'm dumb, remember).
 Maybe DELETE ain't that bad.  We might also try and solicit other opinions on this point.
+ ~- Bryan comment: What I mean is that instead of supporting two separate verbs to two different
URIs (/current and /next) there would be only one URI with two verbs. Additionally, after
some more thought, I think DELETE would be better because it implies that something is being
consumed or deleted, as opposed to POST/PUT which sort of imply something new is being created.
Again, though, I think it is a bit of hair splitting, seeing as how the HTTP spec is going
to have to be bent a little to work right for this particular request anyways. -~
  '''DELETE /[table_name]/scanner/[scanner_id]'''
      Close a scanner. You must call this when you are done using a scanner to deallocate

View raw message