gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Fix expat-configure build failures on Gump
Date Tue, 21 Feb 2012 06:13:40 GMT
On 2012-02-17, Konstantin Kolinko wrote:

> Previous discussion that I found, from August 2010 "expat-configure
> problem" [1], says that the problem is that the build is incompatible
> with new version of autoconf.

> That thread mentions that some servers were building expat
> successfully at that time. But nowadays all Gump servers that I know
> about are failing this build (vmgump, freebsd, Mac OS X (adam)).

"helios" used to be our Solaris zone which has been replaced by the
FreeBSD jail.  It's been the gump.zones.apache.org of that time.

> Is it possible to fix this issue?

> I see that [1] mentions two possible workarounds
> a.  apply some fix

I re-read the thread and it mentions running "autoreconf" as script but
I'm not familiar enough with the toolchain to know whether it would need
to be run before or instead of a specific step.  expat-buildconf looks
as if it passed to Gump but if you look at the actual output it doesn't
seem healthy to me either[2]

> b.  use system-provided version of expat

Unless anybody can provide more information on the autoreconf solution
this might be the only way to go.  Can't promise when I'll find time to
look into it, though.

Stefan

[1] http://marc.info/?t=128146620400019&r=1&w=2
[2] http://vmgump.apache.org/gump/public/expat/expat-buildconf/gump_work/buildscript_expat_expat-buildconf.html

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message