gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy-Lambert <anto...@gmx.de>
Subject Re: Failing test-ant and test-ant-no-xerces since Feb 1st
Date Fri, 25 Feb 2011 20:21:25 GMT
On 2/23/2011 12:33 AM, Stefan Bodewig wrote:
> On 2011-02-23, Antoine Levy-Lambert wrote:
>
>> I have noticed that test-ant and test-ant-no-xerces are both failing
>> since a while on gump. The reason is unclear for me.
> It started when I changed Ant to pass the bootclasspath to cloned VMs as
> well.  I must admit I've been surprised by this myself since I didn't
> expect AntUnit tests to be affected by this at all.
Thanks I will look at this code change.
> Unfortunately it hasn't managed to buble to the top of my TODO list so
> far.
No worries.
>> The error message is
>> BUILD FAILED
>> /srv/gump/public/workspace/ant/src/tests/antunit/taskdefs/import-test.xml:42: Cannot
find
>> override.xml imported from /srv/gump/public/workspace/ant/src/tests/antunit/taskdefs/import-test.xml
>
> Probably the import is using a classloader to load it and not the file
> system.  It may be a simple issue of adding the correct directory as
> <work>  entry to the test-ant descriptor.
>
Yes, it is using a classloader.
<import>
<javaresource name="override.xml">
<classpath location="importtests"/>
</javaresource>
</import>
Let me add the work entry. Just to get the nagging away and see whether 
we get into other problems.
>> I just ran the tests of ant on my PC at work and found no issues with
>> this particular test.
> You didn't use build.sysclasspath=only, did you?
I did not.
> Stefan
>
Regards,
Antoine

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message