gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Gump on adam.a.o trouble with Forrest build
Date Sun, 09 Jan 2011 05:02:32 GMT
David Crossley wrote:
> David Crossley wrote:
> > Stefan Bodewig wrote:
> > > 
> > > I haven't looked at forrest's build file but I assume the <java> task
> > > you use to start Cocoon forks a new VM which does not see the system
> > > properties set for the VM used by Ant.
> > 
> > Ah, i wondered about that. Yes it does.
> > 
> > > You could explicitly set the headless property in your <java> task or
> > > you can try to set the system property ant.build.clonevm[1] to true from
> > > inside your Gump descriptor (I'll do so shortly) which should copy over
> > > the system properties from Ant's VM including the headless one.
> > 
> > The latter would be better. Thanks.
> 
> That got past the hang on adam now thanks.
> 
> Some new strangeness. We now need to require "jakarta-regexp"
> (on vmgump and zone too).
> We must have been getting this for free, prior to adding
> the "clonevm".
> 
> Anyway, added now in r1056590.

Mmmm, things are getting worse since adding the "clonevm".
The "forrest-test-basic" project that used to work are now
failing with configuration problems.

I don't know how to debug this. Any ideas?

Otherwise i think perhaps revert the metadata,
get a build output when it is working again, save it.
Then try again, and compare the broken output results.

-David

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message