gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <ste...@apache.org>
Subject [Fwd: Re: Who broke my gump build?]
Date Mon, 19 Mar 2007 16:36:14 GMT

Another little Gump success story :)

-------- Original Message --------
Subject: Re: Who broke my gump build?
Date: Mon, 19 Mar 2007 13:01:57 +0100
From: Xavier Hanin <xavier.hanin@gmail.com>
Reply-To: ivy-dev@incubator.apache.org
To: ivy-dev@incubator.apache.org
References: <45FE70E4.5090004@apache.org>	 
<635a05060703190455s151b2d4cma4f38ee2347329e3@mail.gmail.com>

On 3/19/07, Xavier Hanin <xavier.hanin@gmail.com> wrote:
>
> On 3/19/07, Steve Loughran <stevel@apache.org> wrote:
>
> >
> >
> >
> > http://vmgump.apache.org/gump/public/smartfrog/smartfrog/gump_work/build_smartfrog_smartfrog.html
> >
> >
> > ivy-init:
> > [ivy:configure] Loading
> > jar:file:/x1/gump/public/workspace/ivy/build/artifact/ivy-
> > 18032007.jar!/org/apache/ivy/core/settings/ivy.properties
> > [ivy:configure] :: Ivy 1.5.0-incubating-local-20070318221846 -
> > 20070318221846 :: http://incubator.apache.org/ivy/ ::
> > [ivy:configure] :: loading settings :: file =
> > /x1/gump/public/workspace/smartfrog/smartfrog/ivyconf.xml
> > [ivy:configure] DEPRECATED: 'ivyconf' element is deprecated, use
> > 'ivysettings' instead
> > (file:/x1/gump/public/workspace/smartfrog/smartfrog/ivyconf.xml)
> >
> > BUILD FAILED
> > /x1/gump/public/workspace/smartfrog/smartfrog/build.xml:838: impossible
> > to configure ivy with given file:
> > /x1/gump/public/workspace/smartfrog/smartfrog/ivyconf.xml
> > :java.text.ParseException: failed to load settings from
> > file:/x1/gump/public/workspace/smartfrog/smartfrog/ivyconf.xml: io
> > problem while parsing config file: JAR entry
> > org/apache/ivy/core/settings/ivyconf-local.xml not found in
> > /x1/gump/public/workspace/ivy/build/artifact/ivy-18032007.jar
> >
> > Total time: 5 minutes 13 seconds
> >
> > This has to be a regression; everything works with 1.4.1 release
>
>
> Yes, the problem is related to IVY-438, renaming configuration to settings
> as discussed before on this list. The problem is that ivyconf-*.xml files
> have been renamed to ivysettings-*.xml. But I'm surprised it works with
> 1.4.1, because before renaming those files to ivysettings, they were moved
> from fr/jayasoft/ivy/conf to org/apache/ivy/core/settings. So I don't see
> how it can work with 1.4.1... Mmm, except if you use the
> ivy.default.conf.dir variable which has been refactored. So ok, this can
> be considered as a regression, I will package the renamed settings file with
> their old names too (as I did with antlib.xml file).
>

I've just checked in a build.xml doing the packaging trick, hope it will fix
your gump build.

- Xavier

Sorry for the trouble,
> - Xavier
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message