gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: JUnit test failure on MacOSX
Date Mon, 15 May 2006 02:01:26 GMT

"Sander Temme" <sctemme@apache.org> wrote in message 
news:3C37092C-A56F-40DE-99B2-21740DC0BE5A@apache.org...
> See: http://clarus.apache.org/junit/junit/gump_work/ 
> build_junit_junit.html
>
> And, this appears to be on MacOSX only, since both vmgump and  gump.zones 
> show the junit entry as green in the logs.
>
> It seems that a single test is failing because it expects a different 
> return value from a subprocess. No idea what would be different, no  time 
> to investigate and I fear I lack applicable knowledge in the  Java space.
>
> Anyone know what could be happening and why?
>

Well, from the JUnit code, the subprocess is basically:
  $JAVA_HOME/bin/java -cp . org.junit.runner.JUnitCore 
org.junit.tests.JUnitCoreTest$Fail

That *should* end up calling System.exit(1), which in turn *should* cause 
'java' to return a status code of 1 to the caller.  I don't know OS/X enough 
to have a guess as to which of these isn't happening.

> I'll be happy to give any committer who wants to give this a gander  an 
> account on Clarus.
>
> S.
>
> -- 
> sctemme@apache.org            http://www.temme.net/sander/
> PGP FP: 51B4 8727 466A 0BC3 69F4  B7B8 B2BE BC40 1529 24AF
>
>
> 




---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message