gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <ste...@apache.org>
Subject Re: what version of the maven2 ant tasks are installed?
Date Thu, 23 Feb 2006 15:53:06 GMT
Bill Barker wrote:
> "Steve Loughran" <stevel@apache.org> wrote in message 
> news:43FDD5EB.80109@apache.org...
>> Bill Barker wrote:
>>> "Steve Loughran" <stevel@apache.org> wrote in message 
>>> news:43FD86D7.6030009@apache.org...
>>>> I'm getting a build failing because the <pom> task of maven2 is absent:
>>>>
>>>> /x1/gump/public/workspace/antbook/diary/core/core-chapter-10-maven.xml:113:

>>>> Problem: failed to create task or type 
>>>> antlib:org.apache.maven.artifact.ant:pom
>>>> Cause: The name is undefined.
>>>>
>>>> What version of the m2 tasks is gump running? 2.0.0? Upgrading to 2.0.2 
>>>> would be handy
>>> I'm pretty certain that no version of Maven2 is installed (Gump can't do 
>>> anything with it, so why install it).
>> The maven2 ant tasks are there. Otherwise smartfrog-xml wouldnt be failing 
>> with the m2 tasks unable to resolve dependencies :)
> 
> You're right, and from maven2-ant-tasks.xml, it v2.0-a3. 

I see. I think an upgrade is in order, but as 2.0.3 will ship soon, 
let's not worry about it this week.

> I also see that 
> antbook isn't <depend />ing on it, so that might be a problem as well :). 

that I can fix :)



---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message