gump-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Graham Leggett" <minf...@sharp.fm>
Subject Problems with <configure> tag in a project
Date Fri, 14 Oct 2005 14:05:50 GMT
Hi all,

I am still having hassles with C/C++ projects and dependencies. I have a
project that depends on other projects, and is configured like this:

  <project name="hoops-feed-configure">
    <configure>
      <arg name="--prefix" path="dest-@@DATE@@"/>
      <arg name="--with-hoops" project="hoops-make-install"
           reference="home" path="dest-@@DATE@@"/>
      <arg name="--with-monacoxml" project="monaco-xml-make-install"
           reference="home" path="dest-@@DATE@@"/>
    </configure>
    <depend project="hoops-make-install"/>
    <depend project="monaco-xml-make-install"/>
    <license name="LICENSE.txt" />
  </project>

The resultant configure line from the above looks like this:

  configure
    --with-hoops=/udd001/hoops/gump/work/hoops
    --with-monacoxml=/udd001/hoops/gump/work/monaco-xml
    --prefix=/udd001/hoops/gump/work/hoops-feed/dest-13102005

The key difference is the missing path in --with-hoops and
--with-monacoxml. In both cases, it picks the project source ddirectory up
correctly, but as the path of "dest-@@DATE@@" is ignored, the library is
being searched for in the wrong place, and ./configure fails.

Is there a different way I should configure the project tag?

Regards,
Graham
--


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@gump.apache.org
For additional commands, e-mail: general-help@gump.apache.org


Mime
View raw message